我要投搞

标签云

收藏小站

爱尚经典语录、名言、句子、散文、日志、唯美图片

当前位置:九肖六肖三肖全年资料 > 取变体型 >

全部币求大神 分析一下 精易模块正则表达式 问题 (小白宗旨每帖

归档日期:06-06       文本归类:取变体型      文章编辑:爱尚语录

  小白看不懂刚学习一个多星期.精易模块正则用的时候有时候卡死 .想自己写. 精易模块正则表达式类 源码 求大神写上注释 分析一下

  小白看懂的都在后面写了备注其他的小白有些看不懂 求大神写上注释 分析一下 (小白宗旨每帖比采纳.大神辛苦了)

  根据指定的正则表达式文本创建一个正则表达式对象。本对象中的原有内容将被释放

  可以留空,默认为假,不区分大小写; 真为区分大小写;本参数指定这个正则表达式在创建成功后进行匹配、搜索、替换时,是否区分大小写;

  可以留空,默认为真,允许匹配多行; 如果本成员值为真,字符“^”不仅匹配目标文本的开头,而且匹配目标文本中换行符(字符(10),字符(13)或 #换行符)的后面;字符“$”不仅匹配目标文本的结尾,而且匹配目标文本中换行符的前面。否则字符“^”仅仅匹配目标文本的开头,“$”也仅仅匹配目标文本的结尾。

  可空。默认为不替换。说明:正则表达式文本为【formhash value=7b4aa6c5】,这里面的引号处理起来很麻烦,直接把此参数设置为真,把换成 #引号 再传进来就可以了,如:【formhash#引号 value=#引号7b4aa6c5】

  是否匹配多行 =选择(是否为空(是否匹配多行), 真, 是否匹配多行)看懂了#########

  是否全局匹配 =选择(是否为空(是否全局匹配), 真, 是否全局匹配)看懂了#########

  正则.写属性(“IgnoreCase”, 是否区分大小写)匹配时不区分大小写

  集_过度对象 = 正则.对象型方法(“Execute”, 集_被搜索的文本)

  输出调试文本(“友情提醒:正则类 → 创建() 命令的参数二 → 被搜索的文本 的长度过长,可以会导致程序直接结束。”)

  集_过度对象 = 正则.对象型方法(“Execute”, 被搜索的文本)

  返回(正则.文本方法(“Replace”, 集_被搜索的文本, 用作替换的文本))

  .子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用

  .子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用

  .子程序 创建, 逻辑型, 公开, 根据指定的正则表达式文本创建一个正则表达式对象。本对象中的原有内容将被释放

  .参数 正则表达式文本, 文本型, , 比如“易语言4\.0(模块支持库)?”

  .参数 是否区分大小写, 逻辑型, 可空, 可以留空,默认为假,不区分大小写; 真为区分大小写;本参数指定这个正则表达式在创建成功后进行匹配、搜索、替换时,是否区分大小写;

  .参数 是否匹配多行, 逻辑型, 可空, 可以留空,默认为真,允许匹配多行; 如果本成员值为真,字符“^”不仅匹配目标文本的开头,而且匹配目标文本中换行符(字符(10),字符(13)或 #换行符)的后面;字符“$”不仅匹配目标文本的结尾,而且匹配目标文本中换行符的前面。否则字符“^”仅仅匹配目标文本的开头,“$”也仅仅匹配目标文本的结尾。

  .参数 自动替换引号, 逻辑型, 可空, 可空。默认为不替换。说明:正则表达式文本为【formhash value=7b4aa6c5】,这里面的引号处理起来很麻烦,直接把此参数设置为真,把换成 #引号 再传进来就可以了,如:【formhash#引号 value=#引号7b4aa6c5】

  是否区分大小写 = 取反 (选择 (是否为空 (是否区分大小写), 假, 是否区分大小写)) 看懂了#########

  是否匹配多行 = 选择 (是否为空 (是否匹配多行), 真, 是否匹配多行) 看懂了#########

  是否全局匹配 = 选择 (是否为空 (是否全局匹配), 真, 是否全局匹配) 看懂了#########

  正则.写属性 (“IgnoreCase”, 是否区分大小写) 匹配时不区分大小写

  局_正则文本 = 子文本替换 (正则表达式文本, “#引号”, #引号, , , 真)

  集_过度对象 = 正则.对象型方法 (“Execute”, 集_被搜索的文本)

  输出调试文本 (“友情提醒:正则类 → 创建() 命令的参数二 → 被搜索的文本 的长度过长,可以会导致程序直接结束。”)

  集_过度对象 = 正则.对象型方法 (“Execute”, 被搜索的文本)

  .子程序 取正则文本, 文本型, 公开, 返回以文本形式表示的正则表达式。如果该对象尚未创建,则返回空文本。本命令为高级对象成员命令

  返回 (正则.文本方法 (“Replace”, 集_被搜索的文本, 用作替换的文本))

  .参数 起始位置, 整数型, 参考 可空, 可以被省略,提供参数数据时只能提供变量。该命令调用成功后,本参数存放取得的子文本在整个被搜索文本中的起始位置

  .子程序 取子匹配文本, 文本型, 公开, 取出该正则的子表达式匹配到的文本

  .参数 子表达式索引, 整数型, , 欲取其值的子表达式,该参数对应与正则表达式中的一个子表达式以圆括号( )为标记,索引从1开始

  .参数 起始位置, 整数型, 参考 可空, 可以被省略,提供参数数据时只能提供变量。该命令调用成功后,本参数存放取得的子文本在整个被搜索文本中的起始位置

  .子程序 取子匹配数量, 整数型, 公开, 取出该正则的子表达式匹配到的数量

  返回 (集_过度对象.读对象型属性 (“Item”, 0).读对象型属性 (“SubMatches”, ).读数值属性 (“Count”, ))全部金币求大神分析一下 精易模块正则表达式 问题

  因为类似正则.创建,这就是一个创建正则表达式的过程而已。了解也就是明白了创建需要哪些代码,当然,如果你属于已经充分了解了怎么去写正则表达式,现在想要深入了解原理,你可以看一下。(我的意思很简单,楼主会不会花很大时间只是去学习原理,好比开车去研究发动机的发动原理而忽视了实际开车的一些技能)

  这种正则的代码是死的,并不是因为有了易语言它才是这么写,而是别人把它移植到易语言也可以用,就像md5算法,你说md5算法不好,你要改进他,但是你不懂他的算法,你问别人他是怎么算的,然后别人巴拉巴拉跟你说了一堆,你是懂了,可是懂了不等于你会改进它,改进是另辟蹊径去想。

  --------------------支持论坛发展,购买终身“赞助会员”用户组,全站附件永久免精币免回复下载,更享有多项特权--------------------

  这种正则的代码是死的,并不是因为有了易语言它才是这么写,而是别人把它移植到易语言也可以用,就像md5算 ...

本文链接:http://odigallery.com/qubiantixing/130.html